A Tale of Two NAS’s

Finally I met with success in two Network Attached Storage devices on my home network. Surprisingly, both at the same time, but different solutions.

I have a Synology DS1010+ that has been in use for the better part of a decade and I also had a FreeNAS homebuilt computer. The Synology’s job was for Plex media storage (PMS) and mass file storage. 5x 2 TB drives in a Synology Hybrid RAID (SHR) array. For a few years, the admin portal kept telling me there was array errors, yet all the files were accessible and the drive checks out were good. I purchased a WD 10 TB USB 3.0 drive on President’s day and painstakingly copied all the files from the Synology to the single drive over the past few days. I then wiped the Synology and let it rebuild over about 10 hours. When I brought it back up, SHR was not an option when creating the array. Only normal RAID levels. So I selected RAID 5 and went on my way. 24 hours later, no array errors are present. I think it’s fixed. Also, I found out how to use Domain Admins as admin accounts for the Synology (joined to Active Directory, obviously).

As far as the FreeNAS, apparently the motherboard was dying. I found a suitable replacement and used the latest version of FreeNAS, which is a completely different GUI. It seems to be working much better and I don’t have any errors when using Veeam to backup my VMware ESX server. This is the exclusive purpose of the FreeNAS system. It has 3x 2 TB drives in a ZFS RAID 5 array. The protocol is SMB. iSCSI proved too much hassle to get working. I’ve done it before, but simple Windows share is fine for me.

That’s all today, folks. Maybe next time I’ll announce my new 10 GbE network.

Leave a Reply

Your email address will not be published.